QUESTION: 


I updated this module to version 1.2.8, while still working on M2 version 2.2.10 for this project.

  • During compilation, these errors occur:
    Errors during compilation: Bss\CustomerAttributes\Plugin\Integration\Model\Customer\DataProvider
    Extra parameters passed to parent construct: $fileUploaderDataResolver. File: /xxxx/xxxx/xxxx/xxxx/vendor/bsscommerce/customer-attributes/Plugin/Integration/Model/Customer/DataProvider.php
    Total Errors Count: 1
  • When opening a customer in the backend, an error appears isB2BRegistrationModuleEnabled() on null, with result that customers cannot be edited/saved

How to fix it?


ANSWER:


The error happened due to the fact that module version 1.2.8 is not compatible with M2.2.x.


To resolve this issue, please edit the file app/code/Bss/CustomerAttributes/Plugin/Integration/Model/Customer/DataProvider.php as below:


Or download the attached file below and overwrite the current file on your site.


If you have any other question or concern, please feel free to contact us. We'd be happy to support!