QUESTION:

My site's Magento version is 2.2.6 and we don't use Amazon_Payment method so I disabled it by code. 

After I installing the version 2.1.9 of the module I get this error on the console: Failed to load the "Bss_OneStepCheckout/js/view/place-order-btn" component. 

Can you help me with this?


ANSWER:

The error happens since you disabled the module by code so that the js of Amazon is not loaded which causes the error.


In this case, please hotfix by edit file as below:


Or download the attached file and overwrite the current file on your site. 


Also, if you don't use the Amazon payment method, please disable it in the backend config instead of disabling it by code to avoid any issue.


If there is anything else we might help you, please do not hesitate to contact us via https://bsscommerce.com/contact

We'd be happy to support.