QUESTION:


We have installed the extension Magento 2 Custom Order Number v1.1.0 on my Magento 2.2.0 but the following error appears when I tried to create order and clicked to Save button. Could you please advice how to fix this? 


ANSWER:


This error appears due to the fact that our module is not compatible with M2.2.0.


To fix this error, please download the attached files below and overwrite the current files on your site. 

The files changed: 

app/code/Bss/CustomOrderNumber/Model/OrderIncrementIdChecker.php

app/code/Bss/CustomOrderNumber/Plugin/Model/Quote.php 


If you need further assistance, please don't hesitate to contact us.