Question:

I have an error ‘You need to choose options for your item’ error when you try and add an item to the Cart. 


Answer:


Ajax Add To Cart for Magento 2 version v1.1.5

Configurable Product Wholesale Display for Magento 2 version v.1.1.4


In this case, it is assumed that's because of conflict between M2 Ajax Add To Cart and Configurable Product Wholesale Display extension. To solve this issue, could you please replace the current file by this attached one on your site?
This is the path of file:

/public_html/app/code/Bss/AjaxCart/Controller/Index/Index.php


After that, please edit file: /public/app/code/Bss/AjaxCart/Model/Observer/ProductAddToCartAfter.php

Add line 63
$this->registry->unregister('last_added_quote_item');


Please note that, it's just the solution for your reference.


For more information about product, please refer Configurable Product Wholesale Display and Ajax Add To Cart pages.

If you need any further assistance, please feel free to contact us.

Please visit our site for more useful Magento 2 Extensions: https://bsscommerce.com/magento-2-extensions.html