Question:

I actually wanted to upgrade your extension to 1.2.1 but got an error message, so I went back to my original version.

and the error i get at setup:upgrade after upgrading your module to 1.2.1 is:

[ReflectionException]                                                
  Class Magento\Framework\Serialize\Serializer\Serialize does not exist


Answer:

The issue is due to an incompatibility issue on Magento 2.1.x.

Please use the patch below to overwrite the files on your site and fix the issue.

- app/code/Bss/Simpledetailconfigurable/Helper/ModuleConfig.php ModuleConfig.php

- app/code/Bss/Simpledetailconfigurable/Model/Import/Preselect.php Preselect.php


Please let us know if you have any other issues.

We are always willing to support.